Bug #2915

Same serial number for all Microsoft Office 2010 installations

Added by Lukasz Raj about 2 years ago. Updated over 1 year ago.

Status:ClosedStart date:03/30/2015
Priority:NormalDue date:
Assignee:Guillaume Rousse% Done:

90%

Category:inventory
Target version:2.3.17
For junior contributor:No

Description

There is same serial number in all Microsoft Office Home & Business 2010 POLISH in glpi.
The serial is like XXXXX-XXXXX-XXXXX-XXXXX-DVXGV for all of them.
I thought it is a bug in fusioninventory so I've checked it with Winkeyfinder 1.75 and it was still wrong (ends with DVXGV).
Correct serial is shown in Belarc Advisor (on my computer it is XXXXX-XXXXX-XXXXX-XXXXX-JVB9D instead of XXXXX-XXXXX-XXXXX-XXXXX-DVXGV shown in glpi)
also this software/script shows it correctly http://www.autoitscript.com/forum/topic/131797-windows-and-office-key/
Server: Glpi 0.85.2 (Centos 6.6)
Client: Fusioninventory 2.3.16, 2.3.13, 2.3.10.1 + Windows XP, Windows 7, Windows 8.1 (over 40 PC's)

Best regards
Clerk

office_2010_reg_info.zip (68.1 KB) Lukasz Raj, 04/15/2015 12:51 PM

wow6432.office14_office2010-home_sb_polish.reg.zip - we have 32polish version of 2010 home&sb polish (71.1 KB) Milosz Engel, 05/28/2015 07:22 AM

History

#1 Updated by Guillaume Rousse almost 2 years ago

  • Status changed from New to Feedback
  • Assignee set to Guillaume Rousse
Please provide relevant registry except, ie:
  • HKLM\SOFTWARE\Microsoft\Office\10.0\Registration for 32-bit version
  • HKLM64\SOFTWARE\Wow6432Node\Microsoft\Office\10.0\Registration for 64-bit version

#2 Updated by Lukasz Raj almost 2 years ago

I think this is the right branch of the registry

#3 Updated by Milosz Engel almost 2 years ago

Hello, my case is very similar to above except my serial ends with "7MBC7". I think this depends on version of office (ours are home and SB). I have tested that on 10 computers - all reporting same serial, although all of them have correct(other and unique) serial entered and are fully activated.
Same thing for Office 2013 home&sb

#4 Updated by Guillaume Rousse over 1 year ago

  • Target version set to 2.3.17
  • % Done changed from 0 to 90

Should be fixed by commit #06c73b8. Can you test and confirm ?

#5 Updated by Lukasz Raj over 1 year ago

I am more than willing to do that but, excuse me my newbie question, where I can find this fixed, executable version?

#6 Updated by Guillaume Rousse over 1 year ago

2.3.17 has not been release yet, you have to retrieve the patch from github, and apply it manually:
https://github.com/fusioninventory/fusioninventory-agent/commit/06c73b884703920db09efa82b297688d6589030d

#7 Updated by Guillaume Bougard over 1 year ago

Hello Lukasz,

we are checking this case too in Teclib actually. I still prepared a 2.3.17 pre-release windows installer for this purpose. I can send you in private a link to the installer if you need.

#8 Updated by Lukasz Raj over 1 year ago

Thank you for the link Guillaume Rousse.
I replaced c:\Program Files\FusionInventory-Agent\perl\agent\FusionInventory\Agent\Tools\License.pm with file from your link. Now I can confirm that it works OK with those configurations:
Windows 7 SP1 32 bit + MS Office 2007 Professional Plus (MS Office wasn't issue in this case but I'd like to check if everything works fine with other versions too,
Windows 7 SP1 32 bit + MS Office 2010 Professional there was wrong key, now it is OK.
Windows 8.1 32 bit + MS Office 2010 Professional there was wrong key, now it is OK.
All of them are polish language versions.
I couldn't check MS Office 2013 because there is no "software licenses" button in glpi for PC's with this version installed. Maybe You could add MS Office 2013 in future releases too as it's product key can be read from registry.

Now I look forward to version 2.3.17 release.

Thank You!

Guillaume Bougard wrote:

Hello Lukasz,

we are checking this case too in Teclib actually. I still prepared a 2.3.17 pre-release windows installer for this purpose. I can send you in private a link to the installer if you need.

Thank you for your offer but I managed to patch this file and I would like to use stable version in my production environment.

Best Regards
Lukasz Raj

#9 Updated by Guillaume Rousse over 1 year ago

  • Status changed from Feedback to Resolved

#10 Updated by Guillaume Rousse over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF