Bug #2876

wrong processor frequency

Added by Didier RAMBEAU over 2 years ago. Updated over 1 year ago.

Status:ClosedStart date:02/14/2015
Priority:NormalDue date:
Assignee:Guillaume Rousse% Done:

100%

Category:inventory
Target version:2.3.17
For junior contributor:No

Description

On one of my physical computer, processeur frequency is wrong, the agent report 3700 Mhz instead of 2400 Mhz. On that computer OCS inventory agent work correctly.

OCS composant clement.png - composants reported by OCS agent (58.1 KB) Didier RAMBEAU, 02/16/2015 07:42 PM

FI composant clement.png - composants reported by FI agent (59.3 KB) Didier RAMBEAU, 02/16/2015 07:42 PM

FI ordinateur clement.png - version of FI agent (52 KB) Didier RAMBEAU, 02/16/2015 07:43 PM

dmiresult.txt Magnifier - dmidecode file (20.5 KB) Didier RAMBEAU, 02/17/2015 07:56 PM

central processor.reg - registry value (2.51 KB) Didier RAMBEAU, 02/17/2015 07:58 PM

proc.txt Magnifier (1.97 KB) Didier RAMBEAU, 03/07/2015 10:47 AM

History

#1 Updated by Guillaume Rousse over 2 years ago

  • Category set to inventory
  • Status changed from New to Feedback
  • Assignee set to Guillaume Rousse

I'm sorry, my crystal ball is broken, I have to way to guess what operating system, and what agent version you are using...

#2 Updated by Didier RAMBEAU over 2 years ago

It was on a windows 7 operating system with last version of fusioninventory agent (2.3.15) as you can see in the hard copy attachments

#3 Updated by Guillaume Rousse over 2 years ago

Server screenshots are useless if that's an agent issue. So, first check in agent output that it is indeed an agent issue, and not just a server presentation issue.

If it is an agent issue, please provide dmidecode output, as well as registry content for HKEY_LOCAL_MACHINE/Hardware/Description/System/CentralProcessor key.
If it is a server issue, just transfer this ticket to the correct tracker: http://forge.fusioninventory.org/projects/fusioninventory-for-glpi/issues

See http://www.fusioninventory.org/documentation/bugreport/ for details.

#4 Updated by Didier RAMBEAU over 2 years ago

It's an agent bug :

extract of .OCS file generated by FI agent

<HARDWARE>
<ARCHNAME>MSWin32-x64-multi-thread</ARCHNAME>
<CHASSIS_TYPE>Desktop</CHASSIS_TYPE>
<CHECKSUM>131071</CHECKSUM>
<DEFAULTGATEWAY>192.168.0.254</DEFAULTGATEWAY>
<DNS>192.168.0.254</DNS>
<ETIME>8</ETIME>
<IPADDR>192.168.0.15</IPADDR>
<LASTLOGGEDUSER>Fox</LASTLOGGEDUSER>
<MEMORY>6079</MEMORY>
<NAME>CLEMENT-PC</NAME>
<OSCOMMENTS>Service Pack 1</OSCOMMENTS>
<OSNAME>Microsoft Windows 7 Entreprise </OSNAME>
<OSVERSION>6.1.7601</OSVERSION>
<PROCESSORN>1</PROCESSORN>
<PROCESSORS>3200</PROCESSORS>
<PROCESSORT>AMD Athlon(tm) II X2 245 Processor</PROCESSORT>

here are the requested file

#5 Updated by Guillaume Rousse about 2 years ago

I forgot to ask for the result of a WMI query for Win32_Processor class:
wmic path Win32_Processor get /Format:list > <somefile>

#6 Updated by Didier RAMBEAU about 2 years ago

here is the requested result

#7 Updated by Guillaume Rousse almost 2 years ago

  • Status changed from Feedback to Resolved
  • Target version set to 2.3.17
  • % Done changed from 0 to 100

The issue is caused by usage of 'Max speed' value reported by dmidecode (3200 Mhz) as the CPU speed, whereas it is actually the maximum CPU speed supported by the motherboard. The actual CPU speed is 2900 Mhz (not 2400 Mhz).

Fixed in commit #c5d8409.

#8 Updated by Guillaume Rousse over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF